Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
System Fault Management Administrator's Guide: HP-UX 11i v1 > Chapter 5 Troubleshooting SFM

Troubleshooting Instance Providers

» 

Technical documentation

Complete book in PDF
» Feedback
Content starts here

 » Table of Contents

 » Glossary

 » Index

This section describes techniques for troubleshooting instance providers, such as the CPU Instance Provider, Memory Instance Provider, Filter Metadata (FMD) Provider, and Environmental Providers.

Problem

The serial number and part number property of memory modules, or bulk power supplies are not available.

Cause

Either or both of the following can be the cause of this problem:

  • These properties are not supported on the system.

  • The provider is not configured properly.

Solution

Complete the following steps to check whether the part number and serial number are supported on the given system, and whether the provider is configured properly:

  1. Enter the following command at the HP-UX prompt:

    # mstm

  2. Select System in the product list.

  3. Click Tools -> Information -> Run.

    If the name of the property is displayed in the output, the property is supported.

NOTE: Not all properties are supported on every supported system.

Problem

Requests for instances do not return any value.


Cause 1

The Common Information Model Object Manager (CIMOM) is not running.

Solution

Enter the following command at the HP-UX prompt:

# ps -eaf | grep cimserver

If the name cimserver is displayed in the output, the CIMOM is running properly. If cimserver is not displayed in the output, stop the CIMOM by entering the following command at the HP-UX prompt:

# cimserver -s

To restart the CIMOM, enter the following command at the HP-UX prompt:

# cimserver

Cause 2

The provider is not registered properly.

Solution

Enter the following command at the HP-UX prompt:

# cimprovider -ls | grep SFMProviderModule

If the following output is displayed, all the providers are registered properly:

SFMProviderModule OK

If the output displayed is different from this output, the provider module is not registered. To register the provider module, enter the following command at the HP-UX prompt:

# cimmof -nroot/PG-InterOp /opt/sfm/schemas/mof/SFMProvidersR.mof

If no errors are displayed, the provider module is registered successfully. If errors are displayed, restart the CIMOM by entering the following command at the HP-UX prompt:

# cimserver

After the CIMOM restarts, enter the following command at the HP-UX prompt to register the provider module:

# cimmof -nroot/PG-InterOp /opt/sfm/schemas/mof/SFMProvidersR.mof

After the provider module is registered, create a link between the SFM providers and the CIMOM by entering the following command at the HP-UX prompt:

# ln -s /opt/sfm/lib/libsfmproviders.1 /opt/wbem/providers/lib/libsfmproviders.sl

To check whether the link is created, enter the following command at the /opt/wbem/providers/lib directory:

# ls

Following is a sample output indicating that the link is created:

# lrwxr-xr-x 1 root sys 30 Jan 12 6:56 libsfmproviders.sl -> /opt/sfm/lib/libsfmproviders.1

If the link is already present, the following error message appears:

# ln: /opt/wbem/providers/lib/libsfmproviders.sl exists

Problem

First request on systems does not return with required information immediately.

Cause

Requested information is being collected. The following message is displayed:

Inventory is being built currently. Please try after some time.

Solution

Wait a while, then request for the information again. Providers respond with requested information when information has been gathered.

Problem

Indications fulfilling the conditions defined in the HP-Known HP-Defined filters, are not logged in the Event Archive.

Cause

The HP-Known filters and HP-Known subscriptions have been deleted from the CIMOM.

Solution

Create the following EnumerateInstances.xml file and save it in any location:

EnumerateInstances.xml ->
<?xml version="1.0" encoding="utf-8"?>
   <CIM CIMVERSION="2.0" DTDVERSION="2.0">
      <MESSAGE ID="25000" PROTOCOLVERSION="1.0">
         <SIMPLEREQ>
            <IMETHODCALL NAME="EnumerateInstances">
               <LOCALNAMESPACEPATH>
                  <NAMESPACE NAME="root"/>
                  <NAMESPACE NAME="cimv2"/>
               </LOCALNAMESPACEPATH>
            <IPARAMVALUE NAME="ClassName">
               <CLASSNAME NAME="HP_KnownFilter"/>
            </IPARAMVALUE>
         </IMETHODCALL>
      </SIMPLEREQ>
   </MESSAGE>
</CIM>

To execute the file, enter the following command at the HP-UX prompt:

# wbemexec <full path>/EnumerateInstances.xml

The full path is the absolute path of the EnumerateInstances.xml file.

This recreates HP-Known filters and HP-Known subscriptions in the CIMOM repository, and the indications start logging in the Event Archive.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 2006 Hewlett-Packard Development Company, L.P.